Back to Blog

Rails 6 drops support for PostgreSQL version less than 9.3

on April 10, 2019
This blog is part of our Rails 6 series.

Rails 6.0 was recently released.

Before Rails 6, Rails was supporting PostgreSQL from version 9.1 and above. But in Rails 6, support for versions less than 9.3 is dropped. If your PostgreSQL version is less than 9.3 then an error is shown as follows.

1Your version of PostgreSQL (90224) is too old. Active Record supports PostgreSQL >= 9.3.

Travis CI uses PostgreSQL 9.2 by default in their images. So this error can occur while testing the app on Travis CI with Rails 6. It can be resolved by using an addon for PostgreSQL.


You might also like

If you liked this blog post, check out similar ones from BigBinary